Shannon ! Thanks !

a DIY, modified Mullard 5-20 monoblock design

Shannon ! Thanks !

Postby IGGY » Sun Nov 03, 2013 6:14 pm

Shannon ;) Thanks for wonderful project.

The Eiclone KT120 is up and running and sound awesome O:)

Iggy
Attachments
3995 one.JPG
3995 one.JPG (108.23 KiB) Viewed 5400 times
User avatar
IGGY
 
Posts: 81
Joined: Wed Nov 21, 2007 6:22 pm

Re: Shannon ! Thanks !

Postby Shannon Parks » Mon Nov 04, 2013 9:01 am

Looking great! Just in time for winter heating, too. (lol)

What speakers are they driving?

Shannon
User avatar
Shannon Parks
Site Admin
 
Posts: 3762
Joined: Tue Mar 18, 2003 5:40 pm
Location: Poulsbo, Washington

Re: Shannon ! Thanks !

Postby IGGY » Mon Nov 04, 2013 6:25 pm

Thanks (b)
Yep ! is ready for winter Shannon. Right now need to burn in, so I bias about 72 ma for now and sound so sweet already. I like to try 80 ma. later.
She drive my DIY line arrays.

Best Regards,
Iggy
Attachments
005a.JPG
005a.JPG (130.31 KiB) Viewed 5372 times
User avatar
IGGY
 
Posts: 81
Joined: Wed Nov 21, 2007 6:22 pm

Re: Shannon ! Thanks !

Postby hilldweller » Fri Nov 22, 2013 7:00 pm

IGGY wrote:Shannon ;) Thanks for wonderful project.

The Eiclone KT120 is up and running and sound awesome O:)

Iggy

Awesome job!!! Kudos.
You inspired me to build one. Would you share with me the part #s of the Edcor trannys you used? I plan to run KT-120's as well. Thanks and enjoy, Great Job!!!
You can PM me this if you want, It would be very appreciated.
Analog is Real! Experience it!
Digital leads to trans humanism. Not good.
User avatar
hilldweller
KT88
 
Posts: 285
Joined: Wed Aug 01, 2007 5:28 pm
Location: St. Louis Missouri USA

Re: Shannon ! Thanks !

Postby IGGY » Fri Nov 22, 2013 10:29 pm

PM send...... ;)

Iggy
User avatar
IGGY
 
Posts: 81
Joined: Wed Nov 21, 2007 6:22 pm

Re: Shannon ! Thanks !

Postby hilldweller » Fri Nov 29, 2013 8:18 pm

IGGY wrote:Shannon ;) Thanks for wonderful project.

The Eiclone KT120 is up and running and sound awesome O:)

Iggy

How are they running with your modifications? Still working good and stable? I hope they are. You did a fine job! (d)
Analog is Real! Experience it!
Digital leads to trans humanism. Not good.
User avatar
hilldweller
KT88
 
Posts: 285
Joined: Wed Aug 01, 2007 5:28 pm
Location: St. Louis Missouri USA

Re: Shannon ! Thanks !

Postby IGGY » Sat Nov 30, 2013 6:18 am

Yes ! Still break-in yet, but bias very stable. I love the sound of big KT120 .

Regards,

Iggy
User avatar
IGGY
 
Posts: 81
Joined: Wed Nov 21, 2007 6:22 pm

Re: Shannon ! Thanks !

Postby hilldweller » Sat Nov 30, 2013 6:39 am

IGGY wrote:Yes ! Still break-in yet, but bias very stable. I love the sound of big KT120 .

Regards,

Iggy

I was concerned about the power supply capacitors as they are only rated for 400v in series would be 800v
Also the bias supply voltage would go up as well. What are you biasing at? (???)
Analog is Real! Experience it!
Digital leads to trans humanism. Not good.
User avatar
hilldweller
KT88
 
Posts: 285
Joined: Wed Aug 01, 2007 5:28 pm
Location: St. Louis Missouri USA

Re: Shannon ! Thanks !

Postby tomlang » Sat Nov 30, 2013 7:18 am

Curious, did you use basically the same power supply for this as the Eiclone calls for? Or, did you upsize, upvoltage, etc. to take advantage of the KT120's higher ratings. Also, what watt capable and impedance output transformers did you use?
User avatar
tomlang
 
Posts: 192
Joined: Sat Sep 26, 2009 8:14 pm
Location: Augusta, GA

Re: Shannon ! Thanks !

Postby hilldweller » Sat Nov 30, 2013 9:04 am

tomlang wrote:Curious, did you use basically the same power supply for this as the Eiclone calls for? Or, did you upsize, upvoltage, etc. to take advantage of the KT120's higher ratings. Also, what watt capable and impedance output transformers did you use?

For the outputs, same impedance but 100 watt.
http://www.edcorusa.com/p/458/cxpp100-ms-4_2k
And for the power trans. I used just one of these to power both amps.
http://www.antekinc.com/details.php?p=714
I also upped the power supply caps to 450v. will fit on board but 20mm taller.
Iggy used two of these for his power transformers,
http://www.edcorusa.com/p/673/xpwr077
Analog is Real! Experience it!
Digital leads to trans humanism. Not good.
User avatar
hilldweller
KT88
 
Posts: 285
Joined: Wed Aug 01, 2007 5:28 pm
Location: St. Louis Missouri USA

Re: Shannon ! Thanks !

Postby tomlang » Sat Nov 30, 2013 9:27 am

Excellent! I was thinking that 475-0-475 v Antek might power both channels of a KT120 amp, glad to see it did. I suspect it had enough filament current available? What did you use for bias?

Did you create a schematic you wish to share?
User avatar
tomlang
 
Posts: 192
Joined: Sat Sep 26, 2009 8:14 pm
Location: Augusta, GA

Re: Shannon ! Thanks !

Postby hilldweller » Sat Nov 30, 2013 11:01 am

tomlang wrote:Excellent! I was thinking that 475-0-475 v Antek might power both channels of a KT120 amp, glad to see it did. I suspect it had enough filament current available? What did you use for bias?

Did you create a schematic you wish to share?

This is still a work in progress. Still acquiring parts. The Antek transformer has two 475v outputs at 460ma and two filament outputs at 4 amp each so one transformer should power two KT120 amps. And at only $57.00, what a bargain! Still working on the bias part.
Analog is Real! Experience it!
Digital leads to trans humanism. Not good.
User avatar
hilldweller
KT88
 
Posts: 285
Joined: Wed Aug 01, 2007 5:28 pm
Location: St. Louis Missouri USA

Re: Shannon ! Thanks !

Postby tomlang » Sat Nov 30, 2013 11:58 am

I'm considering a KT120 "one chassis" build myself. I'm getting 566 vdc to the plates of the output tubes in my LTSpice model using that Antek transformer under dc load of 466ma, both channels connected. If you want the model, let me know.
User avatar
tomlang
 
Posts: 192
Joined: Sat Sep 26, 2009 8:14 pm
Location: Augusta, GA

Re: Shannon ! Thanks !

Postby hilldweller » Sat Nov 30, 2013 1:29 pm

tomlang wrote:I'm considering a KT120 "one chassis" build myself. I'm getting 566 vdc to the plates of the output tubes in my LTSpice model using that Antek transformer under dc load of 466ma, both channels connected. If you want the model, let me know.

Sure, lets have it. ;)
Analog is Real! Experience it!
Digital leads to trans humanism. Not good.
User avatar
hilldweller
KT88
 
Posts: 285
Joined: Wed Aug 01, 2007 5:28 pm
Location: St. Louis Missouri USA

Re: Shannon ! Thanks !

Postby tomlang » Sat Nov 30, 2013 2:35 pm

Draft of course. Even the 1N4007's need to be upped for voltage in a real build. You'll need to remove the .doc at the end.
Attachments
HV PS antek 4t475.asc.doc
(4.77 KiB) Downloaded 203 times
User avatar
tomlang
 
Posts: 192
Joined: Sat Sep 26, 2009 8:14 pm
Location: Augusta, GA

Next

Return to eiclone

Who is online

Users browsing this forum: No registered users and 0 guests