KT88/6550 biasing in eiclones

a DIY, modified Mullard 5-20 monoblock design

KT88/6550 biasing in eiclones

Postby WA4SWJ » Wed Jan 04, 2006 6:50 pm

Hi Shannon,

Quick question - what bias current have you been running on your eiclones with either KT88's or 6550's? I'd like to give my 6550's a try in my eiclones (they currently use EL-34's) but would like to set the 6550 bias as optimally as possible. My OPT's are Dynaclone A431's and I'm using the Dynaclone Mark III equivalent power transformer too.

Thanks a bunch and Happy New Year to all!!!

Regards,
Ed Long
User avatar
WA4SWJ
KT88
 
Posts: 647
Joined: Mon Dec 27, 2004 8:39 pm
Location: Belleview, FL

Postby erichayes » Wed Jan 04, 2006 9:14 pm

Hi All,

The magic numbers I've found for EL34s and KT88s in my 50/50 proto's, which are essentially HF89s with a beefier power supply and some minor front end tweaks, are 60 and 72mA, respectively, per tube with 475 volts on the plates. The tubes just open up at that point, both sonically and on the test bench. Since the Ikes are monoblocks, the power supply should be able to handle that current with little problem.

73
Eric in the Jefferson State
erichayes
KT88
 
Posts: 987
Joined: Fri Jan 23, 2004 9:01 pm
Location: McKinleyville CA

Postby WA4SWJ » Thu Jan 05, 2006 6:24 am

Eric,

Thanks for the info. I'll give those bias points a try with the 6550EH's I have. I'm anxious to try some new things now that I have slightly more time to work on my amps. Incidentally, I'm currently running "Winged C" EL-34's in all 3 eiclones and all have red spots on the plates at 50ma bias.

Best regards to all,
Ed Long
User avatar
WA4SWJ
KT88
 
Posts: 647
Joined: Mon Dec 27, 2004 8:39 pm
Location: Belleview, FL

SED it ain't so

Postby Shannon Parks » Thu Jan 05, 2006 7:11 am

Hi Ed,

I concur with Eric's numbers. I've seen distortion really increase at 50ma in the Ike, and would consider 55mA a mininum.

WA4SWJ wrote:Incidentally, I'm currently running "Winged C" EL-34's in all 3 eiclones and all have red spots on the plates at 50ma bias.


Good grief! They sure would hate to be dropped into the Eico HF-87 then. Glad Thermion always steered me away from SED EL34s. Heck, crank up the bias and burn them up, I say. Yellow_Light_Colorz_PDT_06

Shannon
User avatar
Shannon Parks
Site Admin
 
Posts: 3762
Joined: Tue Mar 18, 2003 5:40 pm
Location: Poulsbo, Washington

Postby TerrySmith » Thu Jan 05, 2006 5:16 pm

I haven't had any problems with SED EL-34's, and I run them hard in my MK-4's. Did have some EH 6CA7 large bottle tubes in there, and you could see the screens glowing in spots, kinda like a toaster!
T. Smith
User avatar
TerrySmith
KT88
 
Posts: 973
Joined: Sat Jan 31, 2004 12:51 pm
Location: Maryville TN

OK in ST-70s

Postby EWBrown » Fri Jan 06, 2006 7:15 am

I've run SED EL34s (as well as JJs) in the ST70 (at 50 mA) with good results. They're definitely not up to 6550 and KT88 capabilities, by a long shot.

/ed B in NH
Real Radios Glow in the Dark
User avatar
EWBrown
Insulator & Iron Magnate
 
Posts: 6389
Joined: Wed Mar 19, 2003 6:03 am
Location: Now located in Clay County, NC !


Return to eiclone

Who is online

Users browsing this forum: No registered users and 1 guest