Slow Volume Control

arduino based linestage using 12B4 tubes

Slow Volume Control

Postby bomberspec » Fri Feb 20, 2015 3:11 pm

I have built my first Budgie Preamp and everything is working. Only problem i'm having is that the volume control is very slow when using a remote. I'm not sure if its a programming or wiring issues and would like help.
bomberspec
 
Posts: 1
Joined: Tue Feb 10, 2015 3:29 pm

Re: Slow Volume Control

Postby Shannon Parks » Sun Feb 22, 2015 2:03 pm

bomberspec wrote:I have built my first Budgie Preamp and everything is working. Only problem i'm having is that the volume control is very slow when using a remote. I'm not sure if its a programming or wiring issues and would like help.



Couple thoughts before we change code:
1) Does it seem to act OK if you do a single Volume Up or Down press? It should turn for about 500ms.
2) If that seems normal, but a continuous press doesn't work right, try another remote. The one you are using may have no repeat code (or one we're not loading into memory properly).

Else if it just is some strange timing error, you can change the volume ON cycle here in the main void loop ():
Code: Select all
  //This turns off a volume UP or DOWN button press after 500ms
  if ((volumeOn == 1) && ((millis() - volumeMillis) > 500)) {
    volumeOn = 0;
    digitalWrite(VOL_EN, LOW); // turns motor off
  } /* if Volume On   */


You can change 500 to 1000. Recompile and load.

Shannon
User avatar
Shannon Parks
Site Admin
 
Posts: 3762
Joined: Tue Mar 18, 2003 5:40 pm
Location: Poulsbo, Washington


Return to budgie preamplifier

Who is online

Users browsing this forum: No registered users and 2 guests

cron