Just finished 100W Poseidon. First tube build.

for Dynaco Mark II/III/IV and DIY PP monoblocks

Just finished 100W Poseidon. First tube build.

Postby maynard999 » Fri Mar 30, 2012 4:43 pm

Got the first one 99% done. Should have the 2nd wired later this week.

Poseidon Rev2 board
Hammond 300BX
Hammond 1650RA (easy wire version)
Hammond 156R choke
Curcio Audio ST7U-B PS board
Hammond HWCHAS1310BK Chassis
Waterjet top plate (CAD available, just ask)
mA Meter (currently have a VU meter in its spot)
Triode/Pentode switch

Sounds great. No hum, good power, and good bass. Took a day to debug. I'm not an electrical engineer. Had to swap F&G and replace R16 with a 56K in the end.

Went with the 300BX to get an extra 5V. Used a simple voltage doubler from TubeCAD to get 12VDC. Original idea was to use that to power a VU driver and a VU meter backlite. Way too much distortion with that hooked up. Since I have the hole I'm switching it over to a 100mA backlit meter. The bouncing VU meter would have been cool though.

http://imageshack.us/photo/my-images/839/dsc01647xg.jpg
http://imageshack.us/photo/my-images/190/dsc01646js.jpg
http://imageshack.us/photo/my-images/818/dsc01648l.jpg
http://imageshack.us/photo/my-images/811/dsc01645u.jpg
http://imageshack.us/photo/my-images/19/dsc01644te.jpg
http://imageshack.us/photo/my-images/194/dsc01643t.jpg
maynard999
 
Posts: 11
Joined: Thu Feb 02, 2012 7:35 pm

Postby TomMcNally » Mon Apr 02, 2012 10:00 am

Good looking amp! Get that second channel working and crank 'em
up and annoy the neighbors!

... tom
User avatar
TomMcNally
Darling du Jour
 
Posts: 2716
Joined: Sat Nov 19, 2005 2:19 pm
Location: Northfield, NJ

Postby highflyin9 » Mon Apr 02, 2012 1:52 pm

Great job, looks excellent! (b)
My DIY Electronics Blog: DIYAudioBlog.com
User avatar
highflyin9
 
Posts: 115
Joined: Tue Jul 27, 2010 7:42 pm
Location: East Coast

Postby maynard999 » Sat Apr 14, 2012 1:07 pm

I've been loving these amps but I have had one complaint. At high volume the sound was a bit muddy. I found myself switching to triode to help things a bit, but it didn't do it all.

I was pretty sure I needed to tweak the negative feedback so my first try was a 680 Ohm at R4 instead of the 1K. Magic! Crystal clear when I have it cranked. Top volume isn't what it was, but I'm starting with 100W output transformers so I have a lot to give.
maynard999
 
Posts: 11
Joined: Thu Feb 02, 2012 7:35 pm


Return to poseidon

Who is online

Users browsing this forum: No registered users and 1 guest