Build of Triode ST35 Kit, Rev. E

for the DIY ST35, the Dynakit and every other PP EL84

Re: Build of Triode ST35 Kit, Rev. E

Postby whaler » Sun Dec 01, 2013 5:49 pm

The amp has been playing stellar until today, it just went silent. Checked the fuse, blown. New one in, same thing.
Took all the tubes out, tested them all on my Eico. All are in really good condition.

Tried turning the amp without the tubes, immediately a roar from the power transformer and the fuse blew, no tubes mind you.

Looked inside, no evidence of stressed components anywhere...

Power transformer bad? HELP!
Attachments
DSC00026.JPG
DSC00026.JPG (526.84 KiB) Viewed 6381 times
whaler
 
Posts: 28
Joined: Thu Sep 19, 2013 11:04 am

Re: Build of Triode ST35 Kit, Rev. E

Postby Shannon Parks » Mon Dec 02, 2013 5:57 am

With it powered off and well drained (sitting for ten minutes or so):
1) Disconnect J1-1 and J1-2.
2) Check D1 and D2 with a DMM set to diode checking mode. Look for an open one direction and around 0.7V the other.

If the diodes look good, I have more tests for you. If one is bad, then go ahead and replace both. And use four - two in series for each diode. This will give us twice the voltage protection. Also check for a shorted (failed) supply capacitor, but usually it's a voltage spike that kills the diode.

Shannon
User avatar
Shannon Parks
Site Admin
 
Posts: 3762
Joined: Tue Mar 18, 2003 5:40 pm
Location: Poulsbo, Washington

Re: Build of Triode ST35 Kit, Rev. E

Postby whaler » Mon Dec 02, 2013 4:27 pm

You were right on the money, one of the diodes is voltage dropping in both direction, .218 one way and the other .198, the other diode is OK.

I went to Radio Shack and totally forgot to get them. I have a bunch of 1N4004 laying around, but I think these are borderline. BTW, in my troubleshooting yesterday, I had remove the secondary b+ from J1, 1 and 2, and the amp powered up fine with just the heaters running. The power transformer was quiet.
whaler
 
Posts: 28
Joined: Thu Sep 19, 2013 11:04 am

Re: Build of Triode ST35 Kit, Rev. E

Postby Shannon Parks » Mon Dec 02, 2013 4:51 pm

I think an occasional spike from the on/off switch creates a large spike which can be greater than the 1000V reverse polarity rating of the diode. Probably we can stick with single 1N4007 at U1 and U2, but need something like .047uF, 250VAC across the on/off switch.

Shannon
User avatar
Shannon Parks
Site Admin
 
Posts: 3762
Joined: Tue Mar 18, 2003 5:40 pm
Location: Poulsbo, Washington

Re: Build of Triode ST35 Kit, Rev. E

Postby whaler » Mon Dec 02, 2013 6:48 pm

Another clue, the black thermistor, or inrush limiter was cracked like it wanted to burst open. A little tap by the finger and it broke. I had some spares so I replaced it already.

I probably have one of those AC caps on a donor unit for the switch, let me look around. If not, I am back at Radio Shack tomorrow for the diodes anyways.

Thanks!
whaler
 
Posts: 28
Joined: Thu Sep 19, 2013 11:04 am

Re: Build of Triode ST35 Kit, Rev. E

Postby whaler » Tue Dec 03, 2013 8:59 pm

Thanks Shannon, your initial diagnosis was 100% correct. The diode was the problem. Probably took a surge. Went to Radio Shack and I got the combo rectifier diode pack with four 1N4007 among others. These all went in as you suggested. Powered up without tubes, no problem or noise! Proceeded to add a switch to connect ground chassis to signal ground in one situation where the preamp needs it to quiet down. See the picture for that, the switch mounts next to the speaker connectors with blue wires. Also, notice the new inrush limiter (black round ceramic disc).
The amp performed stellar again for a couple hours tonight.

Thanks for the expert advise!
Attachments
DSC06539b.jpg
DSC06539b.jpg (201.44 KiB) Viewed 6332 times
whaler
 
Posts: 28
Joined: Thu Sep 19, 2013 11:04 am

Re: Build of Triode ST35 Kit, Rev. E

Postby Shannon Parks » Wed Dec 04, 2013 5:27 am

Excellent! Glad it a cap didn't get damaged in the event. A couple comments:
1) I can't tell from your picture, but make sure that D1 & D2 are two diodes in series, not parallel. Just making sure. ;)
2) Push that CL90 away from the cap.

Shannon
User avatar
Shannon Parks
Site Admin
 
Posts: 3762
Joined: Tue Mar 18, 2003 5:40 pm
Location: Poulsbo, Washington

Re: Build of Triode ST35 Kit, Rev. E

Postby ro7939 » Wed Jun 11, 2014 11:34 am

Greetings all!

Has anyone compared this kit to point to point wired EL84 kit? I have no dog in the PCB vs. point to point fight, just curious. Obviously I'd prefer a PCB kit for it's assembly ease. OTOH some believe point to point wiring sounds better.

All associated components, speakers, and my large dedicated treated room are exemplary. So this application will display the smallest differences between amps of different quality. Speakers are 93 dB, 8 Ohm flat above the bass range, 6 Ohm minimum, low-moderate phase angle, and bass cutoff high 30 Hz range. Active powered Distributed Sub Array employed below 40 Hz.

Jimbo
Last edited by ro7939 on Wed Jun 11, 2014 9:44 pm, edited 1 time in total.
ro7939
 
Posts: 2
Joined: Tue Jun 10, 2014 8:53 pm

Re: Build of Triode ST35 Kit, Rev. E

Postby paart » Wed Jun 11, 2014 7:28 pm

Who sells a "point-to-point" wired El84 kit?
paart
 
Posts: 95
Joined: Mon Jul 17, 2006 8:36 pm
Location: Central PA

Re: Build of Triode ST35 Kit, Rev. E

Postby corndog71 » Wed Jun 11, 2014 8:59 pm

He might be referring to mine which I'm not selling.

Image
some people call me Rob
corndog71
 
Posts: 105
Joined: Thu Feb 03, 2011 10:45 am
Location: midwest

Re: Build of Triode ST35 Kit, Rev. E

Postby jcfardo » Wed Jan 13, 2016 10:08 am

Hi whaler

Are OTs Z565-48?

Thanks
jcfardo
 
Posts: 1
Joined: Thu Aug 04, 2011 5:09 pm

Re: Build of Triode ST35 Kit, Rev. E

Postby henniekuyper » Thu Jan 11, 2018 10:57 am

Good day everyone.

I saw this post, and this is really a nice looking amp!!

What is the dimensions of the chassis?

Kind regards
Hennie :{)
henniekuyper
 
Posts: 2
Joined: Tue May 10, 2011 8:53 am

Re: Build of Triode ST35 Kit, Rev. E

Postby nyazzip » Fri Jan 12, 2018 6:50 pm

my chassis measures about 33 x 24 x 5cm
User avatar
nyazzip
KT88
 
Posts: 1070
Joined: Wed Jan 09, 2008 1:24 am

Previous

Return to stereo 35

Who is online

Users browsing this forum: No registered users and 1 guest